High battery draw

sleepwalker

New member
2
1
3
Hi, in my qx80 I have similar issue, 2015 and 3rd battery changed already. Winter is coming and I started to looking for that issue, to not to be surprised at some morning.
Today I measured "idle" current when car was closed (parked and engine off) and after around 2 minutes current drained from battery stabilized on 159mA. All lamps down, radio down etc.... old school said that idle current should be no higher than 50mA. Tomorrow I will remove fuse by fuse to se what/where the problem is.
Other issue is that car battery is never properly charged, when I start engine voltage jump up to 14,5V for some seconds then jumping up and down around 13-13,5V. When you stop on lights or park car with engine running voltage drop (stop charging) to 12V and then car is eating battery .... NIssan /Infiniti know about this issue and for some people some dealers helping.
 

Tduke7

New member
3
0
1
Hi, in my qx80 I have similar issue, 2015 and 3rd battery changed already. Winter is coming and I started to looking for that issue, to not to be surprised at some morning.
Today I measured "idle" current when car was closed (parked and engine off) and after around 2 minutes current drained from battery stabilized on 159mA. All lamps down, radio down etc.... old school said that idle current should be no higher than 50mA. Tomorrow I will remove fuse by fuse to se what/where the problem is.
Other issue is that car battery is never properly charged, when I start engine voltage jump up to 14,5V for some seconds then jumping up and down around 13-13,5V. When you stop on lights or park car with engine running voltage drop (stop charging) to 12V and then car is eating battery .... NIssan /Infiniti know about this issue and for some people some dealers helping.
I actually found out that in my case it was the module controlling the drivers seat adjustment. I didn't realize it wasn't working as I am only driver and do not change seat adjustment. My friend took car, tried to adjust seat, saw it wouldn't work and measured draw at 700. He replaced module and all is fine. Thank you for responding, though , and hope this might help you.
 
Top