DVD headrest removal

11QX56

New member
2
1
3
Hello,

Just joined this forum. We have a 2011 QX56 and the passenger dvd headrest will not work. It is very faint still picture. I tried turning it on and off and moving the headrest up and down but nothing has worked so far. I wanted to check the connection but I’m not sure how to remove the headrest. Thank you in advance.
 

Qxfam

New member
4
1
3
@marctronixx thank you that will help a lot.
Did you ever fix the screen or had to replace it? Mine stays on but the video plays intermittently.

Having issues with entertainment system. I had one dvd screen not working right, so I purchased another one used from a 2013 QX (mine is 2011) and it looks identical, the connector fits but nothing lights up. I contacted the seller, but I was told that the one I bought is for the 13 only, that for 2011-2012 is a different part, is that accurate? The connectors look identical, the vehicle connector is working properly, I swapped the other screen to verify it.

Has anyone fitted a newer screen onto an older QX?

Thank you for your help.
______________________________
 

marctronixx

Staff member
1,531
66
48
Los Angeles
did you put the used screen in the other seat to test?

do the used screen you purchased look the same as the ones you already have?

do you see any models numbers on the screens?

this is for the qx56 right?

these are the first gen armadas so they should all work. its possible your screen you purchased is faulty.

if you can post photos of the screen you have and the used one you bought that would be helpful as well.
 

Qxfam

New member
4
1
3
did you put the used screen in the other seat to test?

do the used screen you purchased look the same as the ones you already have?

do you see any models numbers on the screens?

this is for the qx56 right?

these are the first gen armadas so they should all work. its possible your screen you purchased is faulty.

if you can post photos of the screen you have and the used one you bought that would be helpful as well.
I don’t know why this post ended up on this thread, was it moved?

I did test the screen on the other seat and the car wiring is ok. They look identical, I am leaning towards a faulty display but I wanted to see if anyone knew about compatibility issues.

I cannot see a part number on the connector or harness.
 

marctronixx

Staff member
1,531
66
48
Los Angeles
there is no compatibility issue within the same generation armada. based on what you're saying (since there are no photos of anything to see), it seems you have a faulty monitor so follow up with the seller.
 

Qxfam

New member
4
1
3
Ok, will do. Thank you for your reply

So, I tried it in my friend’s 2014 QX80 (couldn’t be more thankful for that!) and it works perfectly. So, I thought maybe if I swap components it would work on my QX56...2 hours later ended up swapping the display from the new unit and let the rest of the boards. It works good so far, remote works. After removing from the headrest you can see part numbers and they are indeed different.
I took several pictures but I couldn’t upload, if anyone have a similar issue I would be happy to help.
Thank you.
______________________________
 
Top