• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2010 G37" isn't going to indicate to anybody that you need help. However, "Need help with my 2010 G37" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

Choppy acceleration

darrinswait

New member
14
0
0
So this is weird...the car runs fine. It's a 2000 I30t. I say fine instead of normal, because normal for this car is...different. Regardless, I digress. It starts as usual, it idles as usual and runs down the highway just fine. However, when I try to accelerate anything above a "nominal" increase, it's almost as if the transmission cuts in and out. But maybe it's the engine? Either way, it actually acts as if a rev limiter is at it's limit (though it could not be anywhere near) and the car will not accelerate until I back way off of the pedal and then try to "sneak up" on it, accelerating very gently. I thought it was the transmission fluid level, so I checked it and added some because it was low. And it seemed to help for a while, but after two consecutive 600mi. trips, it's doing it again, and it seems worse when it's warmed up, not so bad when the engine is cold. Suggestions? :confused:
 

Sharky808

New member
4
0
1
Engine lights? Almost feels like a spark plug or coil issue. One of my trucks coil was bad and sputtered (no engine light). Only did that when I was at cruising speed and trying to accel a little. At idle it'll rev and run fine just under slight load it would buck
 

2000i30tGuyAndgGal

New member
2
0
0
so i dunno how much research u have done but there is a tcm problem with that year i guess there was a recall and probably alot of people who had the car didnt ever really try and get on it that hard so i would check the tcm
 
Top