• Hint: Use a descriptive title for your new message
    If you're looking for help and want to draw people in who can assist you, use a descriptive subject title when posting your message. In other words, "2010 G37" isn't going to indicate to anybody that you need help. However, "Need help with my 2010 G37" will. Be as descriptive as you can. Please use common sense... This message can be closed by clicking the X in the top right corner.

2004 QX56 no air coming from front vents

an2ny0830

New member
1
0
0
anaheim
i have an inifinity qx56 with 134k miles my aircon and heater works. My only problem is Ac nor Hot air don't flow in my front vents but flows at the foot outlets and defroster.
How do i fix this? I tried cleaning the cabin filter nothing i did try pulling the fuse then turning it back on as per one recommendation still nothing.

I'm hoping also someone would tell meif it's the blend door actuator controls this i believe there are 3 on the driver side on the passenger side and the not so fun under the center dash?
Also does anybody now how to calibrate or reset this actuator it driving me nuts that air won't flow on the front if it was the feet i wouldn't mind fixing it.
Hope someone could help me out. Thanks in advance
 
Last edited:
G

G-127196

i have an inifinity qx56 with 134k miles my aircon and heater works. My only problem is Ac nor Hot air don't flow in my front vents but flows at the foot outlets and defroster.
How do i fix this? I tried cleaning the cabin filter nothing i did try pulling the fuse then turning it back on as per one recommendation still nothing.

I'm hoping also someone would tell meif it's the blend door actuator controls this i believe there are 3 on the driver side on the passenger side and the not so fun under the center dash?
Also does anybody now how to calibrate or reset this actuator it driving me nuts that air won't flow on the front if it was the feet i wouldn't mind fixing it.
Hope someone could help me out. Thanks in advance
Did yuou ever get this fixed?
 
Top