2000 G20t Laggy Acceleration and Bucking

JKane

New member
Joined
May 25, 2012
Messages
2
Reaction score
0
Points
0
Hey Guys,

Just got myself a 2000 G20t and have been going through everything. When I got the car, I knew it had the problem of having very laggy acceleration when cold. So I replaced:

-Plugs
-Air Filter
-Cleaned MAF
-New Fuel Filter
-Both 02 sensors
- All the basic maintenance items.

What happens is that when I even step on hard on the throttle to rev it in Park, it will bogg down and gradually rise, studdering like crazy. But, if I rev it not so aggressive it is fine.

Also, when I am on the highway at certain speeds it will begin to buck, say around 60 and 70. But, if I let off the gas and get right back into the throttle it is fine.

I have a new MAF on the way, but until then, does anyone have any ideas?

Does the PCM need to be reflashed?

Thanks for the help!
 

Infiniti Master

New member
Joined
Oct 2, 2011
Messages
6
Reaction score
0
Points
0
Secondary Ignition components

Secondary Ignition failures show up at these times when components cant handle the increase in combustion resistance check for OEM cap and rotor good ignition wires and if all else fails an ignition coil
Hey Guys,

Just got myself a 2000 G20t and have been going through everything. When I got the car, I knew it had the problem of having very laggy acceleration when cold. So I replaced:

-Plugs
-Air Filter
-Cleaned MAF
-New Fuel Filter
-Both 02 sensors
- All the basic maintenance items.

What happens is that when I even step on hard on the throttle to rev it in Park, it will bogg down and gradually rise, studdering like crazy. But, if I rev it not so aggressive it is fine.

Also, when I am on the highway at certain speeds it will begin to buck, say around 60 and 70. But, if I let off the gas and get right back into the throttle it is fine.

I have a new MAF on the way, but until then, does anyone have any ideas?

Does the PCM need to be reflashed?

Thanks for the help!
 

JKane

New member
Joined
May 25, 2012
Messages
2
Reaction score
0
Points
0
Thanks for the Reply. So, I just put the MAF in and it seemed to have cleared up the studdering! I haven't driven it so we'll see.

But, I put in a new cap and rotor and also a new set of wires, and now I have a stalling problem. It runs great, but if I rev it and let the RPMs fall, the car will stall out.

Any thoughts?
 
G

G-908114

Clean the butterfly valve or iiac
______________________________
 

kittykachoo

New member
Joined
Jul 11, 2021
Messages
2
Reaction score
0
Points
1
Hey Guys,

Just got myself a 2000 G20t and have been going through everything. When I got the car, I knew it had the problem of having very laggy acceleration when cold. So I replaced:

-Plugs
-Air Filter
-Cleaned MAF
-New Fuel Filter
-Both 02 sensors
- All the basic maintenance items.

What happens is that when I even step on hard on the throttle to rev it in Park, it will bogg down and gradually rise, studdering like crazy. But, if I rev it not so aggressive it is fine.

Also, when I am on the highway at certain speeds it will begin to buck, say around 60 and 70. But, if I let off the gas and get right back into the throttle it is fine.

I have a new MAF on the way, but until then, does anyone have any ideas?

Does the PCM need to be reflashed?

Thanks for the help!
I own the same exact car I will try to check on some things to find out for you but if you could possibly help me with one thing do you know where the location of the map sensor is
 

kittykachoo

New member
Joined
Jul 11, 2021
Messages
2
Reaction score
0
Points
1
does anyone know where the manifold absolute pressure sensor is on a 2000 Infiniti G20 I just bought one and I cannot find it it seems to be the problem
 
Top