infiniti forums   infiniti forums

Go Back   Infiniti Forum > Infiniti Forums (Infiniti SUVs) > Infiniti Midsize SUV Forums > Infiniti QX4 Forum

Advertisements
cars connected social network




Notices


Infiniti Forum: Are aftermarket parts,or ome
Reply
 
Thread Tools Display Modes
  #1  
Old 06-13-2018, 09:47 PM
ihopss ihopss is offline
Junior Member
 
Join Date: Jun 2018
Location: Texas
Posts: 2
Default Are aftermarket parts,or ome

I'm having trouble with my QX4 2001, I put new ignition coils in and a few other parts,
and it's still not running properly, so I took it to the dealer and they said I had to use ome, I bought all quality aftermarket(standard brand) parts.
So my question is has anyone else had this problem.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 12:34 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
infinitiforum.net recognizes that "Infiniti", "Nissan", it's logos and various model names and numbers are registered trademarks of Nissan Motor Co. Ltd.. These terms are used for identification purposes only. infinitiforum.net is not affiliated in any way with Nissan Motor Co. Ltd. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2018 Madison Ross Media Group. All rights reserved. Content published on InfinitiForum.net requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Infiniti? Check out your options at the links below: