infiniti forums   infiniti forums

Go Back   Infiniti Forum > Infiniti Forums (Infiniti Cars) > Infiniti I30 / I35 Forum

Advertisements
cars connected social network cars connected social networking app for ios cars connected social networking app for android




Notices


Infiniti Forum: Very Satisfied Owner
Reply
 
Thread Tools Display Modes
  #1  
Old 09-29-2017, 09:18 AM
thepirate thepirate is offline
Junior Member
 
Join Date: Feb 2016
Location: Austin, TX
Posts: 3
Default Very Satisfied Owner

My 2002 I35 has been in the family since dad bought it a long time ago. It has been in suburban NY, upstate NY, DC, Cali and now TX. Looking out on it in the rain just now, it still looks good and the wax is still beading up. It's quiet, powerful, super comfy leather interior, killer sound, still blows hot and cold.
I get that it's a nicely turned out Maxima, but it seems these cars do not have a great rep, they don't seem to last that long. The re-sale value isn't good and in some respects, it is a fairly unsophisticated chassis - a rigid rear axel, and lots of torque-steer. Not a true sportster, but a quiet, comfortable ride in the best of the Japanese tradition.
Car only has 90k on it and everything works as it should. I should be looking at fresh spark plugs, but cringe at the cost. Probably be $400+ for 6 new plugs installed. I've been running some PRI-G thru it, to keep the innards clean, and she gets great mileage - 27 on the highway, about 23 around town.
I can't really ask for more out of a car, but I just hope it lasts....
Reply With Quote
  #2  
Old 10-31-2017, 04:04 PM
thepirate thepirate is offline
Junior Member
 
Join Date: Feb 2016
Location: Austin, TX
Posts: 3
Default

Follow up to the above. Car has been making a clunking sound in the front end for a while, and seems to be getting worse. Doesn't effect overall steering/handling. I would think this would be bushings shot/going?
Seems that to fix, have to do whole front-end rebuild, tie rod ends, control arms, and then the bushings are pressed in at the factory.
Has anyone else done this? Did it cure the problem? Any suggestions? Thx
Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 07:41 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.
infinitiforum.net recognizes that "Infiniti", "Nissan", it's logos and various model names and numbers are registered trademarks of Nissan Motor Co. Ltd.. These terms are used for identification purposes only. infinitiforum.net is not affiliated in any way with Nissan Motor Co. Ltd. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2017 Madison Ross Media Group. All rights reserved. Content published on InfinitiForum.net requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Infiniti? Check out your options at the links below: