infiniti forums   infiniti forums

Go Back   Infiniti Forum > Infiniti Forums (Infiniti SUVs) > Infiniti Full-Size SUV Forums > Infiniti QX56 Forum

Advertisements
cars connected social network




Notices


Infiniti Forum: New Owner
Reply
 
Thread Tools Display Modes
  #11  
Old 08-06-2018, 09:31 AM
marctronixx marctronixx is offline
Senior Member
SUPER MODERATOR
 
Join Date: Sep 2011
Location: Los Angeles
Posts: 1,133
Default

Thanks for the update primo.

Yo Ontario, i got your pm, and i raise you another PM!
Reply With Quote
  #12  
Old 08-25-2018, 12:14 PM
OntarioQX56 OntarioQX56 is offline
Junior Member
 
Join Date: Aug 2018
Location: London
Posts: 7
Default

Thanks for the information Primo.

Well two weeks after getting my transmission service completed I have not encountered that issue I mentioned before. Thanks Marc for the tibit, it was staring right at my face what the issue was. It doesn't surprise me that it was low on fluid and here is why.

Now I notice when my brakes warm up, they make the worst noise. It's like the pads are glazing the rotors. Looks like the dealership I bought it from cheaped out on pad replacements just to pass safety. Another task to do but at least I can do this one.

Now the one thing that pissess me off and I can't prove who is at fault. Last week I noticed a whine noise coming from the power steering. It wasn't there when I test drove or drove off the lot for the first time. I pop the hood and notice my PS fluid is low. Ok, I'll refill and then examine when I get home to see what was going on. I didn't notice any leaks before but I really wasn't looking for one either. So I get home and find a nick on the SS line to the PS cooler. I was hoping it would be a rubber hose as it would be a simple replacement, however this tiny hole is on the cooler side in which Nissan/Infiniti wants 300 for it up here.
This is the part that really peeves me. The hole is not due to wear and tear or corrosion. Closer inspection I can see the clip for the hose has been moved from the original spot and the hose looks like it's been removed before. However the kicker is whoever did it, used frigging pliers to hold onto the SS tube of the cooler and probably another set to pull the hose out. I can feel the nicks on the tube. Luckily its only a very small pin sized hole which when the low pressure fluid goes through it's more of a mist than squirt. So it may take a while for it to refill. So I don't know how long it has been like this as I would have noticed a puddle sooner, and I don't know who to blame, the dealership that did my tranny service (unlikely as they wouldn't need to work around there), the dealership where I bought it (possibly as they did have to look at the headlights just before I drove off as the idiots didn't do the safety right), or the autobody that had to do some work on that side as carproof reported damage on the driver front side. I'm leaning more towards the autobody, but christ did the dealership that sold it to me just refill the reservoir when it was low and not bother to notice the contamination all over the area of the leak? Sorry just venting.

I have one positive thing to say about the leak, I did find the exterior Tranny cooler that Primo talked about so I'm happy to see that and it's not built into the radiator.

I have a couple of thoughts to seal the leak as I really don't want to replace it with a new part right now. At least it's low pressure so I should be able to repair it. Then replace the crappy brake pads the dealership put on it. I should have seen the warning signs when I noticed enough copper colour brake pad paste all over in the caliper and pads to try and hide how crappy they are.

So even with these problems which are not the fault of the QX56, but human stupidity I'm still enjoying the QX. Just thankful the tranny issue is solved which could have been the most expensive adventure of all these trivial things.
Reply With Quote

  #13  
Old 08-27-2018, 12:57 PM
marctronixx marctronixx is offline
Senior Member
SUPER MODERATOR
 
Join Date: Sep 2011
Location: Los Angeles
Posts: 1,133
Default

Again ive not had any issues with the 2012 and its nearly 78K on the clock, daily driver.
Perhaps they did I the timing recall (?) and the techs were sloppy putting things back together? There’s a LOT of stuff to come out of the engine.

The car is a beast and a quality product. However, if the car was mishandled. Or parlay maintained, even the toughest of cars will show faults.

Sorry to hear you have received a car that was not maintained or cared for, but art least it sounds like your care has an owner who really cares about the car.
Reply With Quote
  #14  
Old 08-28-2018, 07:55 PM
OntarioQX56 OntarioQX56 is offline
Junior Member
 
Join Date: Aug 2018
Location: London
Posts: 7
Default

This one was not in the VIN range for the timing chain issue so it wasn't due to that.

This was in a accident by the original owner and had it repaired a few years back. So this leak would have been going for a while, and I bet that dealership service bay had to fill the PS reservoir at least once (red flag). And it's not like they had this SUV for a month. They had it on their lot for enough time to observe this. Who knows who else test drove it in that time.

Either way, I put a review on google a few days ago about the experience I had there. They did reply about 9 hours ago and the only thing they were concerned about me stating they had used cheap brake pads that I have to change already. Nothing about the safety (headlights) not being done right or the on going leak (power steering). To add insult, they said to bring it into them for servicing other issues I may have soon because of the mileage. Did they not even read when I said my first impression with service was not good? Why would I even let them touch it again? I digress

By no means has this made me like this QX any lesser. I love this truck. So much better than my Escalade. None of these issues are the QX's fault. I did fix the PS leak with a new hose overlapping the knick and seemed to have done the trick. As for brakes, I'll just get new pads and probably rotors and do it properly. Maybe even bleed the lines while I'm at it.

This is probably one of the few vehicles I've owned where I haven't been forced to adding mods or change something to improve the looks or performance. I love it as is. However I wont lie that the Limited edition Tail lights are tempting, or even the front grille.

Marc, I sent you a PM.
Reply With Quote
  #15  
Old 08-29-2018, 08:15 AM
marctronixx marctronixx is offline
Senior Member
SUPER MODERATOR
 
Join Date: Sep 2011
Location: Los Angeles
Posts: 1,133
Default

Love the new front grille and the limited edition tails.. they need to grow on me or i just need to see them in person. Every time i see a newer model qx our i cant se the tails. Photos ive seen they look plastic and cheap but thats just me. If they come down in price ill bite though..

Didn’t know about the accident with the previous owner. Understood. Anyway, glad you are still enjoying the car—this early experience has been a black eye of sorts to Infiniti but i think once you get these prior issues corrected , you should have a great time with the car.
Reply With Quote
  #16  
Old 08-29-2018, 09:55 AM
primov8 primov8 is offline
Junior Member
 
Join Date: Sep 2017
Location: NYC
Posts: 22
Default

Quote:
Originally Posted by OntarioQX56 View Post
This is probably one of the few vehicles I've owned where I haven't been forced to adding mods or change something to improve the looks or performance. I love it as is. However I wont lie that the Limited edition Tail lights are tempting, or even the front grille.
Quote:
Originally Posted by marctronixx View Post
Love the new front grille and the limited edition tails.. they need to grow on me or i just need to see them in person. Every time i see a newer model qx our i cant se the tails. Photos ive seen they look plastic and cheap but thats just me. If they come down in price ill bite though..
I'm also a fan of the Limited tail lights and ended up getting them awhile back.

Reply With Quote
  #17  
Old 08-29-2018, 01:05 PM
marctronixx marctronixx is offline
Senior Member
SUPER MODERATOR
 
Join Date: Sep 2011
Location: Los Angeles
Posts: 1,133
Default

Yeah saw your post primo and I guess I just need to see these in person. They just look like cheap autozone tail lamps. No disrespect is meant.. i just guess I need to see them in person. The vertical black pieces inside the light look like the they melted or something.. lol i dont know what it is, and they are not anywhere near worth the cost...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



All times are GMT -5. The time now is 08:04 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
infinitiforum.net recognizes that "Infiniti", "Nissan", it's logos and various model names and numbers are registered trademarks of Nissan Motor Co. Ltd.. These terms are used for identification purposes only. infinitiforum.net is not affiliated in any way with Nissan Motor Co. Ltd. or any other company listed herein. All information on this site is the opinion of its members and not the opinion of the site itself. ©2018 Madison Ross Media Group. All rights reserved. Content published on InfinitiForum.net requires permission for reprint.
MADISON ROSS MEDIA GROUP MARKETPLACE
Need products for your Infiniti? Check out your options at the links below: